<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="viewport" content="width=device-width" /> 	<link rel="Shortcut Icon" href="/wp-content/uploads/2019/09/Screen-Shot-2019-09-20-at-12.19.27-PM.png" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The Falcon RSS 2.0" href="https://thefalcon.online/feed/" />
<link rel="alternate" type="text/xml" title="The Falcon RSS .92" href="https://thefalcon.online/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The Falcon Atom 0.3" href="https://thefalcon.online/feed/atom/" />

<title>2020-2021 ASSP Election Endorsement &#8211; The Falcon</title>
<link rel="alternate" type="application/rss+xml" title="The Falcon &raquo; 2020-2021 ASSP Election Endorsement Comments Feed" href="https://thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thefalcon.online\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			<style type="text/css">
				</style>
	<link rel='stylesheet' id='farbtastic-css'  href='https://thefalcon.online/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://thefalcon.online/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://thefalcon.online/wp-includes/js/thickbox/thickbox.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://thefalcon.online/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://thefalcon.online/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://thefalcon.online/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://thefalcon.online/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://thefalcon.online/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://thefalcon.online/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.4' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=DM+Serif+Text%3A400%2C700%7COxygen%3A400%2C700%7CBree+Serif%3A400%2C700%7CWork+Sans%3A400%2C700%7CSquada+One%3A400%2C700%7CStaatliches%3A400%2C700&#038;display=swap&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://thefalcon.online/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://thefalcon.online/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://thefalcon.online/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://thefalcon.online/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://thefalcon.online/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://thefalcon.online/wp-content/themes/snoflex/style.css?ver=20200229' type='text/css' media='all' />
<link rel='stylesheet' id='snoadrotate-default-css-css'  href='https://thefalcon.online/wp-content/plugins/sno-ad-rotate/css/widget-default.css?ver=1.0' type='text/css' media='screen' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://thefalcon.online/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.7' type='text/css' media='screen' />
<script type='text/javascript' src='https://thefalcon.online/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/thefalcon.online\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20200107'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://thefalcon.online/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thefalcon.online/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thefalcon.online/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Navigating the COVID-19 outbreak' href='https://thefalcon.online/7164/news/navigating-the-aftermath-of-covid-19-outbreak/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement/" />
<link rel='shortlink' href='https://thefalcon.online/?p=7189' />
<link rel="alternate" type="application/json+oembed" href="https://thefalcon.online/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefalcon.online%2F7189%2Fopinions%2F2020-2021-assp-election-endorsement%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thefalcon.online/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefalcon.online%2F7189%2Fopinions%2F2020-2021-assp-election-endorsement%2F&#038;format=xml" />


<!-- Start of Facebook Meta Tags -->

<meta property="og:title" content="2020-2021 ASSP Election Endorsement" />
<meta property="og:type" content="article" />
<meta name="author" content="Editorial Board" />
<meta property="og:url" content="https://thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement/" />
<meta property="og:image" content="https://thefalcon.online/wp-content/uploads/2019/11/Group-3-900x538.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="538" />
	<meta property="og:site_name" content="The Falcon" />
	<meta property="og:description" content="The Falcon endorses Livvy Nolin for the role of Vice President of Ministries because of her strong background in ministry and leadership, and her clear goals.  For most of her life, Livvy Nolin has found her calling in both ministry and serving in a religious context. At the age of 17, Nolin became an elder..." />
	<meta name="description" content="The Falcon endorses Livvy Nolin for the role of Vice President of Ministries because of her strong background in ministry and leadership, and her clear goals.  For most of her life, Livvy Nolin has found her calling in both ministry and serving in a religious context. At the age of 17, Nolin became an elder..." />
	<meta property="article:section" content="Opinions" />
	<meta property="article:tag" content="" />
<!-- End of Facebook Meta Tags -->



<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body data-rsssl=1 class="sno-animate-active">
<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v4.0"></script>				<script type="text/javascript">
					jQuery(document).ready(function() {
						jQuery(".newsticker3-jcarousellite").jCarouselLite({
        					horizontal: true,
        					visible: 1,
        					auto:7000,
        					speed:2000    					});
					});
				</script><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon foundation-icons fi-x"><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://thefalcon.online/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-main-navigation" class="menu"><li id="menu-item-560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-560"><a href="/">Home</a></li>
<li id="menu-item-176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-176"><a href="https://thefalcon.online/category/news/">News</a></li>
<li id="menu-item-177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-177"><a href="https://thefalcon.online/category/features/">Features</a></li>
<li id="menu-item-173" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-173"><a href="https://thefalcon.online/category/opinions/">Opinions</a></li>
<li id="menu-item-175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-175"><a href="https://thefalcon.online/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-565" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-565"><a href="https://thefalcon.online/scores-and-schedules/">Scores and Schedules</a></li>
</ul>
</li>
<li id="menu-item-6448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6448"><a href="https://thefalcon.online/category/video/">Video</a></li>
<li id="menu-item-4749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4749"><a href="https://thefalcon.online/category/gallery/">Gallery</a></li>
<li id="menu-item-558" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-558"><a href="https://thefalcon.online/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-5153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5153"><a href="https://thefalcon.online/about/editors/">Editors</a></li>
	<li id="menu-item-4747" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4747"><a href="https://thefalcon.online/submit-a-letter/">Submit a Letter</a></li>
</ul>
</li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://thefalcon.online/wp-content/uploads/2019/10/smexylogo2.jpg" class="headerimage" alt="Seattle Pacific University&#039;s Student Newspaper" /></div><div class="headerlink headermedium" style="display:none"><img src="https://thefalcon.online/wp-content/uploads/2019/10/smexylogo2.jpg" class="headerimage" alt="Seattle Pacific University&#039;s Student Newspaper" /></div><div class="headerlink headerlarge"><img src="https://thefalcon.online/wp-content/uploads/2019/10/smexylogo2.jpg" class="headerlink headerimage" alt="Seattle Pacific University&#039;s Student Newspaper" /></div><h1 style="display:none" aria-hidden="true">The Falcon</h1><script type="text/javascript">
						jQuery(document).ready(function(){
							jQuery(".headerlink").click(function(){
								window.location="https://thefalcon.online";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="leaderboardwrap">
	<div id="leaderboard">
	<div class="leaderboardadwrap" style="margin:0px auto;float:none;">
		 </div>
	 
	 	
	</div>
</div>
<div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://thefalcon.online"><img src="https://thefalcon.online/wp-content/uploads/2019/10/smexylogo2.jpg" class="headerimage" alt="Seattle Pacific University&#039;s Student Newspaper" /></a></div><h1 style="display:none">The Falcon</h1><div class="header-icons"><style>.topnavbarleft { padding: 0px; width:auto; }</style><a target="_blank" href="https://thefalcon.online/feed/rss/"><div class="alt-header-social social-border sno-rss dashicons dashicons-rss"><span class="icon-hidden-text">RSS Feed</span></div></a><a target="_blank" href="https://twitter.com/thefalcononline">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a target="_blank" href="https://www.facebook.com/thefalcononline/">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div></div><div class="header-search">	<form method="get" id="searchform6464" action="https://thefalcon.online/">
			<div class="search-button-container" id="searchthis6464">
			<button type="submit" disabled="disabled" id="sno-search-navbar-6464" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s6464" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s6464" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit6464" style="display:none;" value="Search" />
		</form>
	</div></div></div><div class="bottom-menu"><div class='subnavbarwrap sno-sticky'
						data-align='center' 
						data-margin='2' 
						data-style='Blocks' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='40px' 
						data-width='1290'><div class="subnavbarcontainer"><div id="subnavbar"><div id="subnavbarbackground"><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-main-navigation-container"><ul id="menu-main-navigation-1" class="sf-menu sno-bottom-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-560"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-176"><a href="https://thefalcon.online/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-177"><a href="https://thefalcon.online/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-173"><a href="https://thefalcon.online/category/opinions/">Opinions</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-175" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thefalcon.online/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-565"><a href="https://thefalcon.online/scores-and-schedules/">Scores and Schedules</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6448"><a href="https://thefalcon.online/category/video/">Video</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4749"><a href="https://thefalcon.online/category/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-558" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thefalcon.online/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5153"><a href="https://thefalcon.online/about/editors/">Editors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4747"><a href="https://thefalcon.online/submit-a-letter/">Submit a Letter</a></li>
</ul>
</li>
</ul></div></nav><div class="clear"></div></div><ul id='menu-more-bottom' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-bottom" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
							<ul id="add-more-bottom" class="sub-menu"></ul>
							</li>
						</ul></div><div class="clear"></div></div></div></div></div><div class="clear"></div><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap"><div class="innerbackground"><div id='snopostid-7189' class='snopostid'><div id='classic_story' class='sno-story-7189'><div id="content"><div id='contentleft'><div class="postarea"><ul class="snocategories"><li class='blockscategory'><a href='https://thefalcon.online/category/opinions/' rel='category tag'>Opinions</a></li></ul><div role="main"><h1 class="storyheadline">2020-2021 ASSP Election Endorsement</h1><div class="storydeckbottom"></div><div class="storydeck"><p>The Falcon endorses Livvy Nolin for VP of Ministries</p></div><div class="clear"></div><div class="permalinkphotobox"></div><div class="storydetails"><p><span class="storybyline"> <a href="https://thefalcon.online/staff_profile/editorial-board/" class="creditline">Editorial Board</a></span><br /><span class="storydate"><span class="time-wrapper">March 10, 2020</span></span></p></div><div class="sharing sharing-top" data-story-id="7189"><a class='commentscroll' href='https://thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement/#comments ' title='Jump to Comments'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthefalcon.online%2F7189%2Fopinions%2F2020-2021-assp-election-endorsement%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=2020-2021 ASSP Election Endorsement&amp;url=https%3A%2F%2Fthefalcon.online%2F%3Fp%3D7189" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a href="//thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div><span class="storycontent"><p><span style="font-weight: 400;">The Falcon endorses Livvy Nolin for the role of Vice President of Ministries because of her strong background in ministry and leadership, and her clear goals. </span></p>
<p><span style="font-weight: 400;">For most of her life, Livvy Nolin has found her calling in both ministry and serving in a religious context. At the age of 17, Nolin became an elder in her hometown Presbyterian church and a member of the board which eventually elected her church’s future pastor.</span></p>
<p><span style="font-weight: 400;">At Seattle Pacific University, Nolin has found ways to both connect with students and connect with opportunities that on-campus ministries have to offer. For much of her time at SPU, Nolin has served on the leadership team of Group, a worship group which meets most weeks around campus. She also set and accomplished a goal this year of meeting with SMC’s for planning and feedback. Further, Nolin has planned and headed services for Chapel. </span></p>
<p><span style="font-weight: 400;">Currently, Nolin serves on the All Ministry Council (AMC), a group made up of coordinators and advisors from each ministry organization on campus, the same group which is headed by the Vice President of Ministries. </span></p>
<p><span style="font-weight: 400;">In taking on the role of VP of Ministries, Nolin hopes to link ministry organizations on campus and make them more collaborative in involvement.</span><span style="font-weight: 400;"> </span></p>
<p><span style="font-weight: 400;">Further, Nolin has expressed concern about the representation of students, particularly in ministry and worship. Since SPU is made up of people from a range of faith backgrounds and identities, university ministries, according to Nolin, should reflect this diversity. Listening to what students want out of their worship experience is a high priority for Nolin.</span></p>
<p><strong>Correction</strong>: Livvy Nolin&#8217;s last name was spelled incorrectly in the previous version of the story.</p>
</span><div class="clear"></div></div><div class="aboutwriter"><div class='aboutwritertitle'>About the Writer</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><a href="https://thefalcon.online/staff_profile/editorial-board/"><div class='sc_title'>Editorial Board, Author</div></a><div class='sc_bio' style='width:100%;'><p></p><div class='clear'></div></div></div><div class="clear"></div></div></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="true" class="commenttoggle fa fa-minus-square"></div><div class="widgettitle-nonsno">1 Comment</div></div><div id='commentsbody' class='widgetbody' style='display:block;'>


<!-- You can start editing here. -->



<div id="commentblock">


	<p id="comments"><b>One Response to &#8220;2020-2021 ASSP Election Endorsement&#8221;</b></p>



	<ol class="commentlist">



	


		<li class="alt" id="comment-56">

			Maryclaire Nolin on

			
			March 11th, 2020 9:02 am 


			<div class="commenttext">

			<div style="float:left;margin:0px 10px 5px 0px;"><img alt='' src='https://secure.gravatar.com/avatar/663109a14b4fe9ce6a5b354ed0f46ead?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/663109a14b4fe9ce6a5b354ed0f46ead?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></div><p>I’m Livvy’s sister from California and I just wanted to let y’all know that our last name is spelled Nolin, not Nolan. Thank you For endorsing my incredible sister!!!!</p>
<div style="clear:both;"></div>

			</div>



		</li>



	


	


	</ol>



 







<p id="respond">

If you want a picture to show with your comment, go get a <a href="http://en.gravatar.com" >gravatar</a>.</p>





<form action="https://thefalcon.online/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="7189" /></p>






</form>









</div></div><div class="widgetfooter"></div></div></div></div><div id="sidebar"><section><div class='widgetwrap sno-animate sno-sno_text-3' style=''><div style="overflow: hidden;margin-bottom:0px;border-top:0px;background: #eeeeee;"><div class="widget8 widgettitle" role="heading" >Follow us on Twitter!</div></div><div class="clear"></div><div class="widgetbody8" style=""><div class="snotextwidget"><a href="https://twitter.com/thefalcon_spu?ref_src=twsrc%5Etfw" class="twitter-follow-button" data-show-count="false">Follow @thefalcon_spu</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div><div class="widget-expander" style="padding-bottom:0px"></div><div class="clear"></div></div></div></section><section><div class='widgetwrap sno-animate sno-trending-2' style=''><div style="overflow: hidden;margin-bottom:0px;border-top:0px;background: #eeeeee;"><div class="widget8 widgettitle" role="heading" >Trending Stories</div></div><div class="clear"></div><div class="widgetbody8" style=""><div class='trending-row' style='border-top: 1px solid #dddddd;border-bottom: 1px solid #dddddd;margin-bottom: -1px;'><div class="trending-number">1</div><div class="trending-image"><a href="https://thefalcon.online/6994/sports/the-farewell-tour/" title="The Farewell Tour"><img src="https://thefalcon.online/wp-content/uploads/2020/02/Darien-1-300x207.jpg" alt="The Farewell Tour" class="trending-thumbnail"/></a></div><div class="trendingheadline"><p><a class="homeheadline" href="https://thefalcon.online/6994/sports/the-farewell-tour/">The Farewell Tour</a></p></div><div class="clear"></div></div><div class='trending-row' style='border-top: 1px solid #dddddd;border-bottom: 1px solid #dddddd;margin-bottom: -1px;'><div class="trending-number">2</div><div class="trending-image"><a href="https://thefalcon.online/7160/news/classes-will-be-held-online-at-spu/" title="Due to spread of COVID-19, classes will be held online at SPU"><img src="https://thefalcon.online/wp-content/uploads/2020/03/IMG_2674-300x225.jpg" alt="Due to spread of COVID-19, classes will be held online at SPU" class="trending-thumbnail"/></a></div><div class="trendingheadline"><p><a class="homeheadline" href="https://thefalcon.online/7160/news/classes-will-be-held-online-at-spu/">Due to spread of COVID-19, classes will be held online at SPU</a></p></div><div class="clear"></div></div><div class='trending-row' style='border-top: 1px solid #dddddd;border-bottom: 1px solid #dddddd;margin-bottom: -1px;'><div class="trending-number">3</div><div class="trending-image"><a href="https://thefalcon.online/7147/news/dry-campus-rule-explained/" title="Dry campus rule explained"><img src="https://thefalcon.online/wp-content/uploads/2020/02/OSS-1-300x200.jpg" alt="Dry campus rule explained" class="trending-thumbnail"/></a></div><div class="trendingheadline"><p><a class="homeheadline" href="https://thefalcon.online/7147/news/dry-campus-rule-explained/">Dry campus rule explained</a></p></div><div class="clear"></div></div><div class='trending-row' style='border-top: 1px solid #dddddd;border-bottom: 1px solid #dddddd;margin-bottom: -1px;'><div class="trending-number">4</div><div class="trending-image"><a href="https://thefalcon.online/7011/news/struggling-between-passion-and-finance/" title="Struggling between passion and finance"><img src="https://thefalcon.online/wp-content/uploads/2020/02/ASSPPay-1-300x192.jpg" alt="Struggling between passion and finance" class="trending-thumbnail"/></a></div><div class="trendingheadline"><p><a class="homeheadline" href="https://thefalcon.online/7011/news/struggling-between-passion-and-finance/">Struggling between passion and finance</a></p></div><div class="clear"></div></div><div class='trending-row' style='border-top: 1px solid #dddddd;border-bottom: 1px solid #dddddd;margin-bottom: -1px;'><div class="trending-number">5</div><div class="trending-image"><a href="https://thefalcon.online/7164/news/navigating-the-aftermath-of-covid-19-outbreak/" title="Navigating the COVID-19 outbreak"><img src="https://thefalcon.online/wp-content/uploads/2020/03/IMG_2674-300x225.jpg" alt="Navigating the COVID-19 outbreak" class="trending-thumbnail"/></a></div><div class="trendingheadline"><p><a class="homeheadline" href="https://thefalcon.online/7164/news/navigating-the-aftermath-of-covid-19-outbreak/">Navigating the COVID-19 outbreak</a></p></div><div class="clear"></div></div><div class="widget-expander" style="padding-bottom:0px"></div><div class="clear"></div>

</div>

				
		
		</div></section>



				

<!-- widget displayed from cache -->
<section><div class='widgetwrap  sno-animate sno-category-40' style=''><div style="overflow: hidden;margin-bottom:0px;border-top:0px;background: #eeeeee;"><div class="widget8 widgettitle" role="heading" ><a href='/'>Latest Headlines</a></div></div><div class="clear"></div><div class="widgetbody8" style=""><div id='catbox-cat407189' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement/#photo'><img src='https://thefalcon.online/wp-content/uploads/2019/11/Group-3-475x284.jpg' class='enlarge-effect' id='grow-cat407189'  alt='2020-2021 ASSP Election Endorsement' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement/'>2020-2021 ASSP Election Endorsement</a></p><p><span class="time-wrapper"> March 10, 2020</span></p><div class='clear'></div><div style='margin-top:15px'></div><div id='catbox-cat407164' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://thefalcon.online/7164/news/navigating-the-aftermath-of-covid-19-outbreak/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/03/IMG_2674-475x356.jpg' class='enlarge-effect' id='grow-cat407164'  alt='Navigating the COVID-19 outbreak' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://thefalcon.online/7164/news/navigating-the-aftermath-of-covid-19-outbreak/'>Navigating the COVID-19 outbreak</a></p><p><span class="time-wrapper"> March 9, 2020</span></p><div class='clear'></div><div style='margin-top:15px'></div><div id='catbox-cat407160' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://thefalcon.online/7160/news/classes-will-be-held-online-at-spu/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/03/IMG_2674-475x356.jpg' class='enlarge-effect' id='grow-cat407160'  alt='Due to spread of COVID-19, classes will be held online at SPU' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://thefalcon.online/7160/news/classes-will-be-held-online-at-spu/'>Due to spread of COVID-19, classes will be held online at SPU</a></p><p><span class="time-wrapper"> March 6, 2020</span></p><div class='clear'></div><div style='margin-top:15px'></div><div id='catbox-cat407156' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://thefalcon.online/7156/gallery/cultural-engagement-around-the-world-2/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/02/StudyAbroad-3-475x356.jpg' class='enlarge-effect' id='grow-cat407156'  alt='Cultural engagement around the world' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://thefalcon.online/7156/gallery/cultural-engagement-around-the-world-2/'>Cultural engagement around the world</a></p><p><span class="time-wrapper"> March 5, 2020</span></p><div class='clear'></div><div style='margin-top:15px'></div><div id='catbox-cat407154' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://thefalcon.online/7154/gallery/fallen-elm-affects-commuters-2/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/01/SUBTree-475x263.jpg' class='enlarge-effect' id='grow-cat407154'  alt='Fallen elm affects commuters' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://thefalcon.online/7154/gallery/fallen-elm-affects-commuters-2/'>Fallen elm affects commuters</a></p><p><span class="time-wrapper"> March 5, 2020</span></p><div class='clear'></div><div style='margin-top:15px'></div><div id='catbox-cat407151' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://thefalcon.online/7151/gallery/practice-about-to-pay-off-2/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/03/Rowing-9-475x268.jpg' class='enlarge-effect' id='grow-cat407151'  alt='Practice about to pay off' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://thefalcon.online/7151/gallery/practice-about-to-pay-off-2/'>Practice about to pay off</a></p><p><span class="time-wrapper"> March 5, 2020</span></p><div class='clear'></div><div style='margin-top:15px'></div><div id='catbox-cat407054' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://thefalcon.online/7054/features/how-students-take-time-to-destress-during-finals/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/03/DeStress-2-475x288.jpg' class='enlarge-effect' id='grow-cat407054'  alt='How students take time to destress during finals' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://thefalcon.online/7054/features/how-students-take-time-to-destress-during-finals/'>How students take time to destress during finals</a></p><p><span class="time-wrapper"> March 5, 2020</span></p><div class='clear'></div><div style='margin-top:15px'></div><div id='catbox-cat407056' class='catboxthumbsmall' style='margin-left:0px;float:left;'><a href='https://thefalcon.online/7056/features/call-to-curb-climate-change/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/03/AgnieskaPolska-1-370x475.jpg' class='enlarge-effect' id='grow-cat407056'  alt='Call to curb climate change' /></a></div><p><a class='homeheadline' style='font-size:16px; line-height: 1.2em;' href='https://thefalcon.online/7056/features/call-to-curb-climate-change/'>Call to curb climate change</a></p><p><span class="time-wrapper"> March 5, 2020</span></p><div class='clear'></div><div style='margin-top:15px'></div><div class='widget-expander' style='padding-bottom:0px'></div><div class='clear'></div></div></div></section><div class="snoadnetwork"><div class="widgetwrap"><h3>Advertisement</h3><div class="widgetbody3"><div class="advertisementwrap" style="float:none;margin:0px auto;max-width:300px"><!-- Begin AdClerks Zone 6807 -->
<script type="text/javascript">
(function() {
var randpubc = Math.floor((Math.random() * 100000) + 1);
var pubc = document.createElement('script'); 
pubc.type = 'text/javascript'; 
pubc.async = true;
pubc.src = '//cdn.adclerks.com/core/ad2/9672/6807?r='+parseInt(randpubc);
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(pubc, s);
})();
</script>
<div id="pubclerks_6807"></div>
<!-- End AdClerks Zone 6807 --></div></div></div></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://thefalcon.online/7104/opinions/not-everyone-can-afford-to-be-environmentally-conscious/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/03/EnvirConsumption-1-475x342.jpg' id='grow-stb7104'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='2020-2021 ASSP Election Endorsement'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb7104').mouseenter(function() {
   											jQuery('#grow-stb7104').removeClass('shrink');
   											jQuery('#grow-stb7104').removeClass('grow');
   											jQuery('#grow-stb7104').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb7104').addClass('shrink');
   										});});</script><p class='stb-cat'>Opinions</p><p class="relatedtitle"><a href="https://thefalcon.online/7104/opinions/not-everyone-can-afford-to-be-environmentally-conscious/">Not everyone can afford to be environmentally conscious</a></p></li><li class='stb-top-row'><p class='stb-cat'>Opinions</p><p class="relatedtitle"><a href="https://thefalcon.online/7106/opinions/editorial-college-involvement-in-election-vital/">Editorial: College involvement in election vital</a></p></li><li class='stb-top-row'><p class='stb-cat'>Opinions</p><p class="relatedtitle"><a href="https://thefalcon.online/7110/opinions/speaking-truth-to-the-covid-19-outbreak/">Speaking truth to the COVID-19 outbreak</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thefalcon.online/7085/opinions/bezos-pledges-to-donate-8-of-wealth/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/03/Bezos-1-475x332.jpg' id='grow-stb7085'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='2020-2021 ASSP Election Endorsement'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb7085').mouseenter(function() {
   											jQuery('#grow-stb7085').removeClass('shrink');
   											jQuery('#grow-stb7085').removeClass('grow');
   											jQuery('#grow-stb7085').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb7085').addClass('shrink');
   										});});</script><p class='stb-cat'>Opinions</p><p class="relatedtitle"><a href="https://thefalcon.online/7085/opinions/bezos-pledges-to-donate-8-of-wealth/">Bezos pledges to donate 8% of wealth</a></p></li><li class='stb-top-row'><p class='stb-cat'>Opinions</p><p class="relatedtitle"><a href="https://thefalcon.online/7038/opinions/editorial-bloombergs-big-bucks/">Editorial: Bloomberg’s big bucks</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thefalcon.online/7043/opinions/alt-rights-co-opting-of-classical-greco-roman-imagery-unsurprisingly-hearkens-to-nazi-origins/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/02/Graphics-2-1-475x332.jpg' id='grow-stb7043'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='2020-2021 ASSP Election Endorsement'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb7043').mouseenter(function() {
   											jQuery('#grow-stb7043').removeClass('shrink');
   											jQuery('#grow-stb7043').removeClass('grow');
   											jQuery('#grow-stb7043').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb7043').addClass('shrink');
   										});});</script><p class='stb-cat'>Opinions</p><p class="relatedtitle"><a href="https://thefalcon.online/7043/opinions/alt-rights-co-opting-of-classical-greco-roman-imagery-unsurprisingly-hearkens-to-nazi-origins/">Alt-right’s co-opting of classical Greco-Roman imagery unsurprisingly hearkens to Nazi origins</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thefalcon.online/6927/opinions/ice-has-not-melted/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/02/ICE-1-475x280.jpg' id='grow-stb6927'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='2020-2021 ASSP Election Endorsement'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb6927').mouseenter(function() {
   											jQuery('#grow-stb6927').removeClass('shrink');
   											jQuery('#grow-stb6927').removeClass('grow');
   											jQuery('#grow-stb6927').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb6927').addClass('shrink');
   										});});</script><p class='stb-cat'>Featured Stories</p><p class="relatedtitle"><a href="https://thefalcon.online/6927/opinions/ice-has-not-melted/">ICE has not melted</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thefalcon.online/6929/opinions/can-wholesome-media-help-adults/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/02/Untitled_Artwork-475x332.jpg' id='grow-stb6929'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='2020-2021 ASSP Election Endorsement'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb6929').mouseenter(function() {
   											jQuery('#grow-stb6929').removeClass('shrink');
   											jQuery('#grow-stb6929').removeClass('grow');
   											jQuery('#grow-stb6929').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb6929').addClass('shrink');
   										});});</script><p class='stb-cat'>Featured Stories</p><p class="relatedtitle"><a href="https://thefalcon.online/6929/opinions/can-wholesome-media-help-adults/">Can wholesome media help adults?</a></p></li><li class='stb-top-row'><p class='stb-cat'>Opinions</p><p class="relatedtitle"><a href="https://thefalcon.online/6835/opinions/editorial-stop-gutting-public-transportation/">Editorial: Stop gutting public transportation</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thefalcon.online/6838/opinions/is-the-internet-really-holding-celebrities-accountable/#photo'><img src='https://thefalcon.online/wp-content/uploads/2020/02/Graphics-1-475x332.jpg' id='grow-stb6838'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='2020-2021 ASSP Election Endorsement'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb6838').mouseenter(function() {
   											jQuery('#grow-stb6838').removeClass('shrink');
   											jQuery('#grow-stb6838').removeClass('grow');
   											jQuery('#grow-stb6838').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb6838').addClass('shrink');
   										});});</script><p class='stb-cat'>Opinions</p><p class="relatedtitle"><a href="https://thefalcon.online/6838/opinions/is-the-internet-really-holding-celebrities-accountable/">Is the internet really holding celebrities accountable?</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

  							//		animation: 'fade',
  							//		smoothHeight: false,
  							//		customDirectionNav: jQuery("#sfi-navigation span"),
  							//		animationLoop: true,
  							//		slideshow: false,
  							//		touch: true



		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div><div style="clear:both;"></div><div class="footeradboardwrap">
	<div id="footeradboard">
	<div class="footeradboardadwrap" style="margin:0px auto;float:none;">
	<!-- Begin AdClerks Zone 6806 -->
<script type="text/javascript">
(function() {
var randpubc = Math.floor((Math.random() * 100000) + 1);
var pubc = document.createElement('script'); 
pubc.type = 'text/javascript'; 
pubc.async = true;
pubc.src = '//cdn.adclerks.com/core/ad2/9672/6806?r='+parseInt(randpubc);
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(pubc, s);
})();
</script>
<div id="pubclerks_6806"></div>
<!-- End AdClerks Zone 6806 -->
	 </div>
	 
	 	
	</div>
</div>
<div class="footerwrap"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://thefalcon.online">The Falcon</a></p></div><div class="footerright social-classic"><style>.topnavbarleft { padding: 0px; width:auto; }</style><a target="_blank" href="https://thefalcon.online/feed/rss/"><div class="alt-header-social social-border sno-rss dashicons dashicons-rss"><span class="icon-hidden-text">RSS Feed</span></div></a><a target="_blank" href="https://twitter.com/thefalcononline">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a target="_blank" href="https://www.facebook.com/thefalcononline/">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div></div></div><div class="footertagline"><p>Seattle Pacific University&#039;s Student Newspaper</p></div><div class="footersearch">	<form method="get" id="searchform3364" action="https://thefalcon.online/">
			<div class="search-button-container" id="searchthis3364">
			<button type="submit" disabled="disabled" id="sno-search-navbar-3364" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s3364" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s3364" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit3364" style="display:none;" value="Search" />
		</form>
	</div><div class="clear"></div><div class="footermenu"><div class="menu-extra-pages-container"><ul id="menu-extra-pages" class="footer-menu"><li id="menu-item-170" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170"><a href="/">Home</a></li>
<li id="menu-item-172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-172"><a href="https://thefalcon.online/staff/">Staff</a></li>
<li id="menu-item-171" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171"><a href="https://thefalcon.online/about/">About</a></li>
<li id="menu-item-563" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-563"><a href="https://thefalcon.online/submit-a-letter/">Submit a Letter</a></li>
</ul></div></div><div class="footercredit"><p>&copy; 2020  &bull; <a target='_blank' href='https://snosites.com/client-site-privacy-policy/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://thefalcon.online/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-147249547-40', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	<div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/thefalcon.online\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefalcon.online/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/thefalcon.online\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefalcon.online/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.4'></script>
<script type='text/javascript' src='https://thefalcon.online/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
</div><div id="sno_hoversearch"><div class="sno-search-close foundation-icons fi-x" style="float:right;"></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://thefalcon.online/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button fa fa-search"><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><div class="sharing sharing-top" data-story-id="7189"><a class='commentscroll' href='https://thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement/#comments ' title='Jump to Comments'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthefalcon.online%2F7189%2Fopinions%2F2020-2021-assp-election-endorsement%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=2020-2021 ASSP Election Endorsement&amp;url=https%3A%2F%2Fthefalcon.online%2F%3Fp%3D7189" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a href="//thefalcon.online/7189/opinions/2020-2021-assp-election-endorsement//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://thefalcon.online/wp-content/uploads/2019/10/smexylogo2.jpg" alt="Seattle Pacific University&#039;s Student Newspaper" /></a></div><div class="hover_title"><div class="hover_titletext">2020-2021 ASSP Election Endorsement</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://thefalcon.online/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-main-navigation-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-560"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-176"><a href="https://thefalcon.online/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-177"><a href="https://thefalcon.online/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-173"><a href="https://thefalcon.online/category/opinions/">Opinions</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-175"><a href="https://thefalcon.online/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-565"><a href="https://thefalcon.online/scores-and-schedules/">Scores and Schedules</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6448"><a href="https://thefalcon.online/category/video/">Video</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4749"><a href="https://thefalcon.online/category/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-558"><a href="https://thefalcon.online/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5153"><a href="https://thefalcon.online/about/editors/">Editors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4747"><a href="https://thefalcon.online/submit-a-letter/">Submit a Letter</a></li>
</ul>
</li>
</ul></div></ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - jQuery('.footerwrap').height();
				
									WindowHeight -= jQuery('#commentswrap').height();		
								
				
/*
				jQuery('.sno-menu').click(function() {
				
					jQuery('#hoverbar_menu').fadeToggle();
					jQuery('.menu-icon').toggle();
					jQuery('.close-icon').toggle();
					jQuery('#hoverbar_menu').css({ height: jQuery(window).height() - 50 });
				
				});
*/
				
				jQuery(window).scroll(function(event) {
					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
					
	
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
/*
					if ( ScrollPercent > 100 ) {
												jQuery('.sno-arrow-up').css({ background: '#592B2F', color: '#eee'});
						jQuery('.sno-menu').css({ background: '#592B2F', color: '#eee'});
						jQuery('.socialmedia .sharing-icon').css({ opacity: 1 })
						
							
					} else {
												jQuery('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
						jQuery('.sno-menu').css({ background: '#eee', color: '#ccc'});
					}
*/
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
															if( jQuery('.subnavbarwrap').length ) {	
									jQuery('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
								}
														
															var lpb = jQuery('.lf_headerleft').width();
																var rpb = 50 + jQuery('.socialmedia').width();
																	rpb += jQuery('#sno_hoverbar .sno-search-button').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script></body></html>